Error when you select the users menu item

Hi ,
When you click on the “User” item in the menu bar, it throws an error:-

VariableDoesNotExist at /profile/search/

Failed lookup for key [page] in [{‘True’: True, ‘False’: False, ‘None’: None}, {}, {}, {‘paginator’: <helpers.mixins.SafePaginatorMixin.SafePaginator object at 0x7f2e497afd00>, ‘page_obj’: <Page 1 of 37>, ‘is_paginated’: True, ‘object_list’: <QuerySet […

Hi @hakimks ,
please can you share a screen shot showing the link you;re selecting as I can’t seem to reproduce this.


Just to add, I am running v0.12.22 of the server.

that’s a bit odd then, as same link as I thought and working on my local, plus the various staging servers we’ve updated to that version.
Could you email me a dump of this database, so I can have a look?

Have sent it via email.

Thanks @hakimks ,

I just tested this using the core oppia server 0.12.22, and tested against python 3.6 and 3.8, and both of these are working for me. Note that I’m using Ubuntu 18.04 not 20.04. Would be worth testing on your local machine (using that database)?

I am getting the same error on my laptop (windows 10 , running the ubuntu command line app).
Below is the template that is causing the error.
Error during template rendering

In template /mnt/c/Users/OPEN Deliver/COVID-19-Response-Uganda/oppia/django-oppia/templates/profile/list/row-user-default.html, error at line 5
Failed lookup for key [%s] in %r
1 {% load i18n %}
2 {% load display_functions %}
5 {{ forloop.counter0|add:page.start_index }}
6 {{user.username}}
7 {% if OPPIA_SHOW_GRAVATARS %} {{ user|gravatar:24 }} {% endif %}
8 {{ user.first_name }} {{ user.last_name }}
10 {{ user.date_joined|date:“d/m/Y” }}
12 {{ user.last_login|date:“d/m/Y” }}
15 {% trans ‘Edit Profile’ %}

Thanks @hakimks

It looks like something has gone wrong with a merge along the way somewhere…

That file on the core oppia (0.12.22) is different to the one you have for the uganda code… see line 5: django-oppia/row-user-default.html at master · DigitalCampus/django-oppia · GitHub vs django-oppia/row-user-default.html at master · COVID-19-Response-Uganda/django-oppia · GitHub

Thanks @alex
I have deleted that line (5) and its not working.

Is it the same error you get or a different one?

You might want to run a diff on the core oppia code vs the uganda code to see if there are other files that didn;t merge correctly

It was the same error on all (staging, local and live).

I will do this.