OppiaMobile Community

Show gamification events settings in the custom settings file

Hi @alex
I want to turn off the animation and sound by default, using the custom.settings file, but even after changing the following default settings, the animation still appears (with no sound)
GAMIFICATION_POINTS_ANIMATION=0
DURATION_GAMIFICATION_POINTS_VIEW=0

I expected to find a setting like " Show gamification events in this file which i can set to true/false.

Hi @hakimks
I think the issue might be if you have changed the default custom.properties, but then just upgraded the app, rather than a fresh install. Most of the properties are ones which just get loaded as a default preference when the app is first installed, so if an upgrade changes this, it won’t reflect in the app, as the user might have changed their preference, so we don;t overwrite properties where the user can change the preferences.
The reason for not having a true/false is because there are multiple options for the gamification.

Cheers,
Alex

The show gamification events settings is still selected even when you do a fresh install (I have attached a screenshot). and there seems to be no settings to turn this off by default. And the documentation states that:---- Settings and Defaults — OppiaMobile 0.12.21 documentation

GAMIFICATION_POINTS_ANIMATION (int): Defines the animation type if the previous setting Show gamification events is enabled. These are the different types of animation (default is number 3):

Ah ok, there’s no option to have the “show gamification events” turned off by default (in the app config/properties. I’ve added a task for this (see: Log in with Atlassian account)

Probably the only option right now is to set GAMIFICATION_POINTS_ANIMATION=1

yes, no option to turn it off by default. Thx